Joomla! 2.5 Support Is Ending On December 31, 2014!

Undecided if you should migrate to Joomla 3.X or not? After all, your site is running fine. Why rock the boat? Somehow you’ve heard/learned that you need to migrate to a newer life cycle or version and landed here. You’ve come to the right place. This documentation is a funnel. At the bottom of each page there are up to two options to take you to the next step. Now, here are all the reasons to take the plunge to Joomla 3.x!

Learn More

Have more questions? Submit a request


Please sign in to leave a comment.
Powered by Zendesk